[OWASP_OWTF] Steps to install OWTF on KALI 2.0

Vishal Gandhi vkgandhi84 at gmail.com
Tue Dec 29 22:58:42 UTC 2015


Hi Abraham,

I tried this on 18th October using Bootstrap script which didn't work.  I
didn't record errors that I saw on my screen, but then I tried this with
Manual Installation which uses default repository
https://github.com/owtf/owtf.git .  But, installation showed many errors
(most of those related to missing dependencies).  I then started browsing
development branches and tried some, but similar errors until I tried
lions2014 .  But, installation from latest development branch worked fine
for you on new Kali 2 VM.  So, I am thinking this may have something to do
with me upgrading from Kali 1.1.0 to 2.0.

I am thinking to create brand new VM with Kali 2 (instead of upgrading) and
try the latest version of OWTF (the one published as well as development
one) next and see if it works.

I didn't make full use of all the features of OWTF yet, but I'll do so soon
and keep you posted.

Thanks again and you have a joyous and happy new year in advance. :)

On Tue, Dec 29, 2015 at 2:27 PM, Abraham Aranguren <
abraham.aranguren at owasp.org> wrote:

> Hi Vishal,
>
> I noticed you are using a very old branch (lions2014), did that work
> better for you than the current development branch? I tested the
> installation on a brand new Kali 2 VM, with almost nothing installed and
> the installation seems to work ok.
>
> We are still facing multiprocessing issues such as deadlocks during
> scanning, I would be interested to know if scanning works well on some of
> the old branches, that should help us narrow down the problem.
>
> Thoughts?
>
> Thanks and happy new year! :)
>
> Abe
> On 29 Dec 2015 03:39, "Vishal Gandhi" <vkgandhi84 at gmail.com> wrote:
>
>> Hi,
>>
>> I am fairly new to this, but I tried out OWTF in October.  I initially
>> installed it on KALI 1.0 which was smooth, but then upgrading to KALI 2.0
>> left it broken.  So, I tried installing it directly on KALI 2.0.
>>
>> I use VirtualBox virtual machine.  Following are the steps that I
>> followed to successfully install OWTF on KALI 2.0 which hopefully will help.
>>
>>
>> 1.  Clone KALI Template:kali-linux-1.1.0a-i386-v2 [ I had a template of
>> KALI 1.1.0 ]
>> 2.  Upgrade to KALI 2.0
>> 3.  cd /opt
>> 4.  git clone -b lions_2014 https://github.com/owtf/owtf.git
>> 5.  cd /opt/owtf/install
>> 6.  chmod u+x install.py
>> 7.  pip install cffi --upgrade
>> 8.  pip install --upgrade -r /opt/owtf/install/owtf.pip
>> 9.  pip install --upgrade beautifulsoup4 lxml Markdown psycopg2 pycurl six
>> 10. ./install.py
>> 11. cd /opt/owtf/profiles/general
>> 12. In default_backtrack.cfg and default.cfg, change value of
>> TOOL_METASPLOIT_DIR to reflect Metasploit installation directory to the
>> correct one which is /usr/share/metasploit-framework/
>>
>> Thanks.
>>
>>
>>
>> _______________________________________________
>> OWASP_OWTF mailing list
>> OWASP_OWTF at lists.owasp.org
>> https://lists.owasp.org/mailman/listinfo/owasp_owtf
>>
>>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.owasp.org/pipermail/owasp_owtf/attachments/20151229/3bf29828/attachment.html>


More information about the OWASP_OWTF mailing list