[Owasp-o2-platform] [Owasp-dotnet] Help in sorting out the Cat.NET's EnvDTE dependency

Dinis Cruz dinis.cruz at owasp.org
Fri Jul 20 05:52:20 UTC 2012


Yes it did, It had SQL Server and SQL Management studio installed.

So I was able to fix this by embedding the dll into the packaged O2 Exe.

Here is the code (from:
https://github.com/o2platform/O2.Platform.Scripts/blob/master/3rdParty_Tools/Microsoft/CatNet/TM%20-%20RealTime%20Security%20Scan%20v1.4.h20
that
does the trick:

	if("envdte80.dll".local().fileExists())
	{
		"Loading envDte80.dll to make sure it is ok".info();
		"EnvDte on disk: {0}".debug("envdte80.dll".local());
		var assembly = "envdte80.dll".local().assembly();
		"EnvDte from assembly {0} at {1}".debug(assembly.str(), assembly.location());
	}


note that on a box with EnvDTE installed the 'assembly' variable will get
the GAC version


Dinis Cruz

Blog: http://diniscruz.blogspot.com
Twitter: http://twitter.com/DinisCruz
Web: http://www.owasp.org/index.php/O2


On 17 July 2012 21:42, Barry Dorrans <barryd at idunno.org> wrote:

>  Did your EC2 box have SQL Management studio installed?****
>
> ** **
>
> *From:* owasp-dotnet-bounces at lists.owasp.org [mailto:
> owasp-dotnet-bounces at lists.owasp.org] *On Behalf Of *Michael Hidalgo
> Fallas
> *Sent:* Tuesday, July 17, 2012 13:39
> *To:* Dinis Cruz
> *Cc:* OWASP .NET; owasp-o2-platform at lists.owasp.org
> *Subject:* Re: [Owasp-dotnet] [Owasp-o2-platform] Help in sorting out the
> Cat.NET's EnvDTE dependency****
>
> ** **
>
> Hi Dinis,
> Probably this is a non-sense question but, does your user  have CAT.NETinstalled?  I was able to run it and it works perfectly. What about using
> Fusion
>
> http://stackoverflow.com/questions/255669/how-to-enable-assembly-bind-failure-logging-fusion-in-net
>
> By the way I was able to load it and I like it
>
> ****
>
> On Tue, Jul 17, 2012 at 10:52 AM, Dinis Cruz <dinis.cruz at owasp.org> wrote:
> ****
>
> Hi, I'm having a prob created by an EnvDTE dependency and it would be
> great to get some help on it.****
>
> ** **
>
> Here are the details of the problem and screenshots of what it looks like
> when correctly executed: Help in sorting out the Cat.NET's EnvDTE
> dependency<http://diniscruz.blogspot.co.uk/2012/07/help-in-sorting-out-catnets-envdte.html>
> ****
>
> ** **
>
> If you were able to run this ok, please provide your configuration and
> set-up****
>
> ** **
>
> Thx
>
> Dinis Cruz
>
> Blog: http://diniscruz.blogspot.com
> Twitter: http://twitter.com/DinisCruz
> Web: http://www.owasp.org/index.php/O2****
>
>
> _______________________________________________
> Owasp-o2-platform mailing list
> Owasp-o2-platform at lists.owasp.org
> https://lists.owasp.org/mailman/listinfo/owasp-o2-platform****
>
>
>
>
> -- ****
>
> *Michael Hidalgo F.
> OWASP Chapter Leader,Costa Rica.*****
>
> “*If you believe in yourself and have dedication and pride - and never
> quit, you'll be a winner. The price of victory is high but so are the
> rewards.” Paul Bryant*****
>
> ** **
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.owasp.org/pipermail/owasp-o2-platform/attachments/20120720/226d65d6/attachment.html>


More information about the Owasp-o2-platform mailing list