[Owasp-o2-platform] Fix for Windows 7 gacutil build error

Dan Cornell dan at denimgroup.com
Tue Jan 5 08:56:37 EST 2010


All:

Just wanted to send this out and get it in the list archives in case anyone else runs into the same problem.

When I was trying to build the O2 Platform from source (SVN 88) on my Windows 7 VM I ran into an error during the build where the gacutil.exe /i call for O2_External_PostSharp.dll returned 1.  When I tried to run this via the command line I got the error message:

"Failure adding assembly to the cache: Access denied. You might not have administrative credentials to perform this task. Contact your system administrator for assistance."

The workaround is to run Visual Studio as the administrative user and then re-run the build sequence.  To do this right-click on the VS.NET icon and select "Run as administrator"  After that I had no errors in my build.

Thanks,

Dan


Dan Cornell | Principal
------------------------------------------
office 210.572.4400
Follow me on Twitter: @danielcornell
------------------------------------------
DENIM GROUP | Build Integrate Secure





More information about the Owasp-o2-platform mailing list