[Owasp-o2-platform] How to change a parameter?

Dinis Cruz dinis at ddplus.net
Wed Dec 8 23:28:08 EST 2010


Hi Thiago, I don't think you are using the MSI, since the directory you have
below is the one where the Click-Once app is installed and your current user
should have access to it.

To make sure that file is there, can you run this script:

*return "O2_External_O2Mono.dll".assembly();
//O2Ref:O2_External_O2Mono.dll*

When you run it (on for example the 'O2  Simple Script Editor'), open the
Log Viewer first and see if there are any errors in there.

If you want to see what dlls you have already downloaded you can use the
script

*return Environment.CurrentDirectory.files("*.dll");*

Also, can you check that you are able to run the
"*\_Scripts\_Sample_Vulnerabilities\BlackBox
- Exploit Execution.h2*" script (you can use the 'O2 Development
environment' to find it). This script is the generic excecution environment
that loads of Unit Test files like the
*WebGoat_BlackBox_Exploits.cs*script you are trying to run.

It this doesn't work, let me know when you have some time and I can help you
via IM, EtherPad or DimDim,

Dinis


On Wed, Dec 8, 2010 at 5:57 PM, Thiago Stuckert <
thiago.melo.stuckert at gmail.com> wrote:

>
> Which version of O2 are you running? (the MSI or EXE)
>>
>>
> MSI version.
>
>
>> Check out what is currently set-up in the O2 Runtime dir, which you can find out by just executing this script:
>>
>> return Environment.CurrentDirectory;
>>
>>
> C:\Users\thiago\AppData\Local\Apps\2.0\JZ3A5N7N.TY9\QV5PR5V0.9H1\o2_x..tion_2e32faf48a4aa5ef_0001.0000_ffb552acf444d990
>
> Do you know what permissions I have to change?
> --
> Thiago
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.owasp.org/pipermail/owasp-o2-platform/attachments/20101209/8ed54842/attachment.html 


More information about the Owasp-o2-platform mailing list