<div dir="ltr">Ideally the wiki would default to the language specified by the browser locale in the absence of a specific profile preference.  That way, people see the language they use most when it is available unless they request otherwise.  Not sure the wiki supports that but we can look.<div><div><br></div><div>Matt <br></div></div></div><div class="gmail_extra"><br><div class="gmail_quote">On Thu, Dec 4, 2014 at 4:22 PM, Josh Sokol <span dir="ltr"><<a href="mailto:josh.sokol@owasp.org" target="_blank">josh.sokol@owasp.org</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div>Mine is already set to "English", but I don't believe that setting will take effect unless you are authenticated with the wiki.  If you are just surfing as an anonymous user it defaults to Spanish (from what I can tell) and you have to manually select a different language.  I believe this sets a cookie for the new language, but that setting is cleared if you clear your cookies, use a different browser, etc.  Seems weird that our wiki default would be Spanish.  Not to offend an Hispanics on the list, but it does seem like English is the predominant language used at least within our mailing lists, connector, and other OWASP publications.<span class="HOEnZb"><font color="#888888"><br><br></font></span></div><span class="HOEnZb"><font color="#888888">~josh<br></font></span></div><div class="HOEnZb"><div class="h5"><div class="gmail_extra"><br><div class="gmail_quote">On Thu, Dec 4, 2014 at 4:17 PM, Ryan Barnett <span dir="ltr"><<a href="mailto:ryan.barnett@owasp.org" target="_blank">ryan.barnett@owasp.org</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div style="word-wrap:break-word;color:rgb(0,0,0);font-size:14px;font-family:Calibri,sans-serif"><div>Hmm – I did find this Cookie in Chrome -</div><div><br></div><blockquote style="margin:0 0 0 40px;border:none;padding:0px"><div><div style="color:rgb(84,84,84);display:inline-block;margin-right:0.5em;font-weight:bold;vertical-align:top;white-space:pre-wrap;font-family:'Lucida Grande',sans-serif;font-size:11.8181819915771px;text-align:left;background-color:rgb(255,255,255)">Cookie:</div><div style="font-family:Menlo,monospace;white-space:pre-wrap;font-size:11px!important;display:inline;margin-right:1em;word-break:break-all;margin-top:1px;color:rgb(48,57,66);text-align:left;background-color:rgb(255,255,255)">wikiLanguageSelectorLanguage=es</div></div></blockquote><div><br></div><div>After logging in, I went into my Account preferences and it says -</div><div><br></div><div><img src="cid:C38BB73B-95A0-4494-BA89-860E255376FD" type="image/png"></div><div><br></div><div>I had to delete those cookies and now it looks OK.</div><span><div><br></div><div><div><font face="Calibri,Verdana,Helvetica,Arial"><span style="font-size:11pt"><div>-- </div>Ryan Barnett<br>Trustwave SpiderLabs</span></font><div><font face="Calibri,Verdana,Helvetica,Arial"><span style="font-size:11pt">ModSecurity Project Leader<br>
OWASP ModSecurity CRS Project Leader</span></font></div></div></div><div><br></div><div><br></div></span><span><div style="font-family:Calibri;font-size:11pt;text-align:left;color:black;BORDER-BOTTOM:medium none;BORDER-LEFT:medium none;PADDING-BOTTOM:0in;PADDING-LEFT:0in;PADDING-RIGHT:0in;BORDER-TOP:#b5c4df 1pt solid;BORDER-RIGHT:medium none;PADDING-TOP:3pt"><span style="font-weight:bold">From: </span> Josh Sokol <<a href="mailto:josh.sokol@owasp.org" target="_blank">josh.sokol@owasp.org</a>><br><span style="font-weight:bold">Date: </span> Thursday, December 4, 2014 5:05 PM<br><span style="font-weight:bold">To: </span> Ryan Barnett <<a href="mailto:ryan.barnett@owasp.org" target="_blank">ryan.barnett@owasp.org</a>><br><span style="font-weight:bold">Cc: </span> "<a href="mailto:owasp-leaders@lists.owasp.org" target="_blank">owasp-leaders@lists.owasp.org</a>" <<a href="mailto:owasp-leaders@lists.owasp.org" target="_blank">owasp-leaders@lists.owasp.org</a>><br><span style="font-weight:bold">Subject: </span> Re: [Owasp-leaders] Default Spanish Text in OWASP Template for Mainpage<br></div><div><div><div><br></div><blockquote style="BORDER-LEFT:#b5c4df 5 solid;PADDING:0 0 0 5;MARGIN:0 0 0 5"><div dir="ltr"><div><div>Ryan,<br><br></div>Yes!  I've been having this issue for at least a year now.  Probably longer.  I even said something about it at one point and was told something about clearing my cookies which didn't work.  It didn't sound like something that anyone else was experiencing so I just keep clicking on "English" as you said and chalked it up to some sort of strange PEBKAC issue.  It's nice to know that I'm not alone in this.<br><br></div>~josh<br></div><div class="gmail_extra"><br><div class="gmail_quote">On Thu, Dec 4, 2014 at 3:20 PM, Ryan Barnett <span dir="ltr"><<a href="mailto:ryan.barnett@owasp.org" target="_blank">ryan.barnett@owasp.org</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div style="word-wrap:break-word"><div style="color:rgb(0,0,0);font-family:Calibri,sans-serif;font-size:14px">Does anyone else run into the issue of the default OWASP site template being Spanish text?  I checked the source and see this on the index page (note the "lang=es" param) -</div><div style="color:rgb(0,0,0);font-family:Calibri,sans-serif;font-size:14px"><br></div><div style="color:rgb(0,0,0);font-family:Calibri,sans-serif;font-size:14px"><span style="color:rgb(136,18,128);font-family:monospace;font-size:medium;white-space:pre-wrap"><link </span><span style="font-family:monospace;font-size:medium;white-space:pre-wrap">rel</span><span style="color:rgb(136,18,128);font-family:monospace;font-size:medium;white-space:pre-wrap">="</span><span style="font-family:monospace;font-size:medium;white-space:pre-wrap">stylesheet</span><span style="color:rgb(136,18,128);font-family:monospace;font-size:medium;white-space:pre-wrap">" </span><span style="font-family:monospace;font-size:medium;white-space:pre-wrap">href</span><span style="color:rgb(136,18,128);font-family:monospace;font-size:medium;white-space:pre-wrap">="</span><a href="https://www.owasp.org/load.php?debug=false&lang=es&modules=mediawiki.legacy.commonPrint%2Cshared%7Cmediawiki.skinning.interface%7Cmediawiki.ui.button%7Cskins.vector.styles&only=styles&skin=vector&*" style="font-family:monospace;font-size:medium;white-space:pre-wrap" target="_blank">https://www.owasp.org/load.php?debug=false&amp;lang=es&amp;modules=mediawiki.legacy.commonPrint%2Cshared%7Cmediawiki.skinning.interface%7Cmediawiki.ui.button%7Cskins.vector.styles&amp;only=styles&amp;skin=vector&amp;*</a><span style="color:rgb(136,18,128);font-family:monospace;font-size:medium;white-space:pre-wrap">" /></span></div><div style="color:rgb(0,0,0);font-family:Calibri,sans-serif;font-size:14px"><br></div><div style="color:rgb(0,0,0);font-family:Calibri,sans-serif;font-size:14px">I can go to the login page and then click on English to change it but I was wondering why that is happening.</div><div style="color:rgb(0,0,0);font-family:Calibri,sans-serif;font-size:14px"><br></div><div style="color:rgb(0,0,0);font-family:Calibri,sans-serif;font-size:14px"><div><font face="Calibri,Verdana,Helvetica,Arial"><span style="font-size:11pt"><div>-- </div>Ryan Barnett<br>Trustwave SpiderLabs</span></font><div><font face="Calibri,Verdana,Helvetica,Arial"><span style="font-size:11pt">ModSecurity Project Leader<br>
OWASP ModSecurity CRS Project Leader</span></font></div></div></div><div style="color:rgb(0,0,0);font-family:Calibri,sans-serif;font-size:14px"><br></div><div style="color:rgb(0,0,0);font-family:Calibri,sans-serif;font-size:14px"><br></div></div><br>_______________________________________________<br>
OWASP-Leaders mailing list<br><a href="mailto:OWASP-Leaders@lists.owasp.org" target="_blank">OWASP-Leaders@lists.owasp.org</a><br><a href="https://lists.owasp.org/mailman/listinfo/owasp-leaders" target="_blank">https://lists.owasp.org/mailman/listinfo/owasp-leaders</a><br><br></blockquote></div><br></div></blockquote></div></div></span></div>
</blockquote></div><br></div>
</div></div><br>_______________________________________________<br>
OWASP-Leaders mailing list<br>
<a href="mailto:OWASP-Leaders@lists.owasp.org">OWASP-Leaders@lists.owasp.org</a><br>
<a href="https://lists.owasp.org/mailman/listinfo/owasp-leaders" target="_blank">https://lists.owasp.org/mailman/listinfo/owasp-leaders</a><br>
<br></blockquote></div><br></div>