[OWASP-ESAPI] ESAPI 1.4.1

Jeff Williams jeff.williams at owasp.org
Wed Dec 2 19:51:31 EST 2009


I think Servlet 2.4 is reasonable.  But by all means if there are  
folks out there still using previous versions... Speak now!

--Jeff




On Dec 2, 2009, at 5:02 PM, Jim Manico <jim.manico at owasp.org> wrote:

> ESAPI 1.4 is targeted for Java 1.4+
> ESAPI 2.0 is targeted for Java 1.5+
>
> Jim
>
> On Dec 2, 2009, at 12:50 PM, Ed Schaller <schallee at darkmist.net>  
> wrote:
>
>>> I'm getting ready to release ESAPI 1.4.1rc1 this week. My goals are
>>> minimal:
>>>
>>> 1) Update Maven config to be inline with 2.0 (hence making it a LOT
>>> easier to set up and build)
>>> 2) Fix the broken Oracle encoder
>>> 3) Fix the Logging API
>> ...
>>> Any other thoughts or wishes for 1.4.2x and beyond?
>>
>> I'd really like to get the JSP stuff and the encoder fixes I've done
>> migrated to 1.4 and I can work on it.
>>
>> One question I have though is if there is a target J2EE version for
>> ESAPI
>> 1.4. The reason I ask is to port the EL functions I need to upgrade
>> the
>> tld to JSP 2.0 which implies J2EE 1.4 and Servlet 2.4. Those were
>> released
>> in Nov 2003. Do we need backward compatibility to earlier versions?
>>
>>>>> ------>
> _______________________________________________
> OWASP-ESAPI mailing list
> OWASP-ESAPI at lists.owasp.org
> https://lists.owasp.org/mailman/listinfo/owasp-esapi


More information about the OWASP-ESAPI mailing list