[OWASP-ESAPI] Updating to PDT 2.1

Andrew van der Stock vanderaj at owasp.org
Wed Aug 26 05:23:59 EDT 2009


Hi folks,

I'd like to make one final update to the project that probably should  
have occurred before we all got going: upgrade to PDT 2.1 as the  
development environment. I don't know (nor particularly care) about  
what you use to develop ESAPI for PHP in, but I like to use the latest  
and greatest at the beginning of the project, and leave that alone  
until the project ships.

To that end, do folks mind if I upgrade the .project file to use PDT?  
The alternative is to leave it as is at the moment, and take  
the .project file out of version control (set to ignore) so that it  
doesn't get overwritten.

I am using:

Eclipse 3.5 for PHP (on MacOS X Cocoa)
This includes everything we need to develop here in one easy download

Xdebug 2.0.5

Subclipse 1.6

SimpleTest 1.0.5 plugin

If you do not have these components, testing and debugging can be more  
complex than is truly necessary.

I have a few VMs, I will try to upgrade one of them to PHP 5.3.0 so we  
can test ESAPI on various 5.2.x flavors as well as 5.3.0.

thanks,
Andrew




More information about the OWASP-ESAPI mailing list