[Owasp-boston] starting Webscarab on RH

Chris Eng ceng at Veracode.com
Mon Jan 4 15:52:55 EST 2010


If it can't find the package, your classpath may be incomplete. One possibility: make sure you are using ':' on Linux (as opposed to ';' on Win32) as the separator character when defining the classpath in the startup script.




From: owasp-boston-bounces at lists.owasp.org [mailto:owasp-boston-bounces at lists.owasp.org] On Behalf Of Laverty, Patrick
Sent: Monday, January 04, 2010 3:41 PM
To: owasp-boston at lists.owasp.org
Subject: [Owasp-boston] starting Webscarab on RH

Ok, you guys were a great help last time with my "lite" problem.  So now I'm trying to install and run on my Red Hat machine.  I downloaded the same zip, unzipped it and run the startup command, the wasp artwork comes up but then I get an error:
"main(Framework.extractVersionFromManifest): PKG is null".

So in doing a little search, I see the code where that comes from is here:

    private void extractVersionFromManifest() {
        Package pkg = Package.getPackage("org.owasp.webscarab");
        if (pkg != null) _version = pkg.getImplementationVersion();
        else _logger.severe("PKG is null");
        if (_version == null) _version = "unknown (local build?)";
    }

All the files in the directory have 775 permission on them and I do have the latest JRE running.

Works great on my XP machine, but get these errors on RH.  Any ideas?  I apologize if this is really a "duh" thing.

Thanks.

Patrick

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.owasp.org/pipermail/owasp-boston/attachments/20100104/d8c0937d/attachment.html 


More information about the Owasp-boston mailing list