[Owasp-appsensor-dev] AppSensor v2.0.0 Beta Release

John Melton jtmelton at gmail.com
Thu Sep 18 03:24:46 UTC 2014


Chetan,
Thanks for the excellent feedback - responses inline.

Thanks,
John

On Wed, Sep 17, 2014 at 11:07 PM, Chetan Karande
<chetan.karande at owasp.org> wrote:
> Hi John,
>
> Great work on beta Release. It reflects all the hard work you have put in.
>
> As I am going through the website,  sharing some obeservations /
> suggestions:
>
> 1) Getting Started Page:
>
>  I think this note is misleading:
>
> If you want to try out a working application, start with one of the sample
> applications available on GitHub. You should be able to drop them into a
> servlet container and start them up.

The note _should_ be accurate - the fact that they don't run is an
oversight. You _should_ be able to drop them in a container and have
them run.

>
> Unless I am missing something, starting these sample apps was not as easy
> dropping them in servlet container. On first attempt the 'maven clean
> install' command failed on all sample projects, until I realized the
> repository tag and appsensor-core dependency needs to be fixed for these
> apps as well. The section immediately below this note does specify that, but
> it was not very clear that it applies to sample apps. I think it would be
> helpful to have README.md in each of the sample apps with clear steps on how
> to build these projects (especially helpful for those like me who are not
> very familiar with maven based project structure)
>

I need to clean these up - they didn't get updated when I made changes
so they are broken as of now. This is not terrible since they are
demos, but I'll absolutely correct it.

> Next, even after setting repository and appsensor-core dependency, I
> couldn't get  sample-appsensor-ws-rest-server and simple-websocket-dashboard
> to build successfully due to this error:
>
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-compiler-plugin:3.1:compile (default-compile)
> on project sample-appsensor-ws-rest-server: Fatal error compiling: invalid
> target release: 1.7 -> [Help 1]
>
> I just ran 'maven clean install'  command  at root of these projects. Please
> suggest if I am missing anything.

I'll look at this one, but not sure what's going on here. Assuming I
messed something up with the maven version update and deployment as
these ran just fine recently.

>
>
> 2) JavaScript errors:
>
> I noticed a javscript error is thrown while loading each page: Uncaught
> ReferenceError: $ is not defined. This is due to script tag inside <head>
> tag for each page. It uses jquery before loading it at bottom of the page. I
> didn't find any elements with #tabs id in these html files. So thought this
> script tag has no functional value and can be removed, unless you want to
> move it at bottom of the page after loading jquery.
>
> <script>
>
>       $(function() {
>
>         $( "#tabs" ).tabs();
>
>       });
>
>     </script>

Good catch - this was being used for something, but I removed it. I'll
clean this up.

>
> 3) Are you planning to provide sample client app code as well as part of
> this or future release?

Client app code will come in the future - my goal for pushing forward
with a release is to get just the existing components solidified. I
still have some work to do around looking at the client applications
before putting them out there to be used.


More information about the Owasp-appsensor-dev mailing list