[Owasp-appsensor-dev] AppSensor v2.0.0 Beta Release

Chetan Karande chetan.karande at owasp.org
Thu Sep 18 03:12:39 UTC 2014


John,

Just to clarify, the command I use to build sample apps is 'mvn clean
install' and not 'maven clean install' as I specified in my earlier email.
I could get other two sample projects to build, except
sample-appsensor-ws-rest-server and simple-websocket-dashboard.


Thanks
Chetan

On Wed, Sep 17, 2014 at 11:07 PM, Chetan Karande <chetan.karande at owasp.org>
wrote:

> Hi John,
>
> Great work on beta Release. It reflects all the hard work you have put in.
>
> As I am going through the website,  sharing some obeservations /
> suggestions:
>
> 1) Getting Started Page:
>
>  I think this note is misleading:
>
> If you want to try out a working application, start with one of the sample
> applications
> <https://github.com/jtmelton/appsensor/tree/master/sample-apps> available
> on GitHub. You should be able to drop them into a servlet container and
> start them up.
>
> Unless I am missing something, starting these sample apps was not as easy
> dropping them in servlet container. On first attempt the 'maven clean
> install' command failed on all sample projects, until I realized the
> repository tag and appsensor-core dependency needs to be fixed for these
> apps as well. The section immediately below this note does specify that,
> but it was not very clear that it applies to sample apps. I think it would
> be helpful to have README.md in each of the sample apps with clear steps on
> how to build these projects (especially helpful for those like me who are
> not very familiar with maven based project structure)
>
> Next, even after setting repository and appsensor-core dependency, I
> couldn't get  sample-appsensor-ws-rest-server and
> simple-websocket-dashboard to build successfully due to this error:
>
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-compiler-plugin:3.1:compile
> (default-compile) on project sample-appsensor-ws-rest-server: Fatal error
> compiling: invalid target release: 1.7 -> [Help 1]
>
> I just ran 'maven clean install'  command  at root of these projects.
> Please suggest if I am missing anything.
>
>
> 2) JavaScript errors:
>
> I noticed a javscript error is thrown while loading each page: Uncaught
> ReferenceError: $ is not defined. This is due to script tag inside <head>
> tag for each page. It uses jquery before loading it at bottom of the page.
> I didn't find any elements with #tabs id in these html files. So thought
> this script tag has no functional value and can be removed, unless you want
> to move it at bottom of the page after loading jquery.
>
> <script>
>
>       $(function() {
>
>         $( "#tabs" ).tabs();
>
>       });
>
>     </script>
>
> 3) Are you planning to provide sample client app code as well as part of
> this or future release?
>
>
> Best Regards,
>
> Chetan Karande
>
>
> On Sat, Sep 13, 2014 at 11:38 PM, John Melton <jtmelton at gmail.com> wrote:
>
>> All,
>>
>> I'm happy to announce that the beta release of version 2.0.0 has just
>> been published.
>>
>> The website (http://appsensor.org) has been updated with appropriate
>> documentation, and the release information is published here:
>> https://github.com/jtmelton/appsensor/releases/tag/v2.0.0-beta
>>
>> If you happen to be at AppSecUSA next week, please feel free to share
>> this info freely. I'm targeting Oct/Nov for the 2.0.0 final release,
>> so getting feedback now would be helpful to flesh out any major
>> issues.
>>
>> Please let me know if you have any questions.
>>
>> Thanks,
>> John
>> _______________________________________________
>> Owasp-appsensor-dev mailing list
>> Owasp-appsensor-dev at lists.owasp.org
>> https://lists.owasp.org/mailman/listinfo/owasp-appsensor-dev
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.owasp.org/pipermail/owasp-appsensor-dev/attachments/20140917/879ecdeb/attachment.html>


More information about the Owasp-appsensor-dev mailing list