[Owasp-antisamy] batik-css pom depency

Luke Bunselmeyer LBunselmeyer at EZREZ.COM
Tue Feb 16 23:56:32 EST 2010


I came across a strange issue with parsing CSS selectors with
underscores (_) in them.  I was able to fix the problem by updating the
batik-css POM dependency as detailed below.

 

        == IS ==

        <dependency>

            <groupId>org.apache.xmlgraphics</groupId>

            <artifactId>batik-css</artifactId>

            <version>1.7</version>

        </dependency>

 

        == WAS ==

        <dependency>

            <groupId>batik</groupId>

            <artifactId>batik-css</artifactId>

            <version>1.6-1</version>

        </dependency>

 

Strangely enough, I only had this issue within the beast of my
environment, and I could *not* replicate it in the recent Antisamy
trunk.  Anyway, org.apache.xmlgraphics seems like the appropriate Group
ID.

 

Thanks,

Luke

 


This message may contain confidential information.  If you are not the intended recipient (or authorized to receive for the recipient) and received this message in error; any use, distribution or disclosure is strictly prohibited.  Please contact the sender by reply email and delete all copies of this message from your computer system.  The views and opinions expressed in this email are those of the sender and do not necessarily reflect the views or policies of EzRez Software, except when the sender expressly and with authority states them to be so.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.owasp.org/pipermail/owasp-antisamy/attachments/20100216/f0163aa1/attachment.html 


More information about the Owasp-antisamy mailing list