[Opa] Link issues with binary Mac version

Anand Patil anand.prabhakar.patil at gmail.com
Tue Aug 30 12:22:15 EDT 2011


Hi all,

Thanks for Opa, which looks like a terrific product! I've installed the
binary Mac version, and opa --version says

Opa compiler (c) MLstate -- version S3.5 -- build 520

When I compile the examples in the manual, compilation works and so do the
webpages, but I always get the following warnings:

ld: warning: directory '/opt/mlstate/lib/ocaml/site-lib/zip' following -L
not found
ld: warning: directory '/opt/mlstate/lib/ocaml/site-lib/camlzip' following
-L not found
ld: warning: directory '/opt/mlstate/lib/ocaml/site-lib/ssl' following -L
not found
ld: warning: directory '/opt/mlstate/lib/ocaml/cryptokit' following -L not
found
ld: warning: directory '/opt/mlstate/lib/ocaml/site-lib/cryptokit' following
-L not found
ld: warning: directory '/opt/mlstate/lib/ocaml/site-lib/ulex' following -L
not found
ld: warning: directory '/opt/mlstate/lib/ocaml/site-lib/dbm' following -L
not found
ld: warning: directory 'libsecurity' following -L not found
ld: warning: directory 'appruntime' following -L not found
ld: warning: directory 'libbase' following -L not found

Sure enough, those directories don't exist. They should be:

/opt/mlstate/lib/ocaml/zip
Nothing called 'camlzip' seems to exist
/opt/mlstate/lib/ocaml/ssl
cryptokit is a library, not a directory, at
/opt/mlstate/lib/ocaml/cryptokit.a
/opt/mlstate/lib/ocaml/ulex
/opt/mlstate/lib/ocaml/dbm
libsecurity is a library, not a directory,
at /opt/mlstate/lib/opa/static/libsecurity.a
Same for appruntime
Same for libbase

Thanks!
Anand
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.owasp.org/pipermail/opa/attachments/20110830/9ca9ee77/attachment.html 


More information about the Opa mailing list