[Opa] Opa ubuntu deb

Paulo J. Matos paulo at matos-sorge.com
Tue Aug 30 07:03:15 EDT 2011


Hi,

I just installed OPA deb on Ubuntu 11.04.
When trying to run opa I get:
$ opa test.opa
WARNING : The "server" value is MISSING, the executable will NOT start  
a server
/usr/bin/ld: cannot find -lgdbm_compat
/usr/bin/ld: cannot find -lgdbm
collect2: ld returned 1 exit status
File "caml_startup", line 1, characters 0-1:
Error: Error during linking
make: *** [native] Error 2
error during ocaml compilation -- the command was :
make --makefile=Makefile -W Makefile -j 7 native -s

I tracked this down to the missing library libgdbm-dev

which I sorted with:
sudo apt-get install libgdbm-dev

However, I was expecting the deb to have this one in the dependencies.  
So I just want to report this issue.

Haven't played much with OPA but by the docs alone, looks promising.

Cheers,

-- 
PMatos



More information about the Opa mailing list