[Opa] UTF-8 characters

François-Régis Sinot francois-regis.sinot at mlstate.com
Fri Aug 26 09:28:59 EDT 2011


Hi Jon,

Le vendredi 26 août 2011 à 13:38 +0200, Jon Kleiser a écrit :
> I just discovered and installed Opa on my Mac. I have two questions:
> 
> 1) Under "9.2.3. Strings" in the Opa introduction (index.html) there's a 
> Caution that says ...
> "At the time of this writing, Opa does not offer Utf8 character 
> structures. The only way to insert utf8 characters into your literals is 
> to put the utf8 character in your source code."

> It's not quite clear to me which way that won't work. Could you give me 
> a simple example? I inserted some Norwegian ÆØÅ characters into my 
> hello_web.opa, which is an UTF-8 coded file, like this:
> 
> server = one_page_server("Hello", -> <>Hello, ÆØÅ web!</>)
> 
> ... and that worked OK for me.
> 

Thanks for discovering this sentence, that doesn't mean much. Yes, UTF-8
works well in strings, and that's all most people want. Maybe the
sentence is supposed to mean that we do not have a datatype for single
UTF-8 characters, but that's not a feature we want. I'll remove the
sentence.

> 2) Is it possible to search these 
> <https://lists.owasp.org/pipermail/opa/> archives in some way?

Oh, unfortunately this site does not seem to be written in Opa ;-)
Seriously, I think all these are just static web pages, so without
search. I tried to use google with 'site:', but it's not very
convincing. I agree it's unfortunate.

Best,
François-Régis.

-- 
François-Régis Sinot
R&D @ MLstate
104 rue du Faubourg Saint-Antoine, 75012 Paris, France



More information about the Opa mailing list