[Esapi-user] setting up the Tutorial: can not create a user...

Lukas, Ray Ray.Lukas at supermedia.com
Thu Jun 9 16:48:22 EDT 2011


Hi Guys..

I can not seem to create a user in the users.txt file.. I think that I have everything is setup correctly.. I had to change the port number but, no big deal.. the code seems to run great.. but no user account ever gets created inside of users.txt other than the user admin, which I think was always there.. ...
I can create (at least it looks that way on the web page) an account ray_lukas with password Corvette!#2010
But trying to log into that account produces

- [SECURITY SUCCESS Anonymous:574475 at unknown -> /SwingSetInteractive/SwingSet] Invoked LoginLab.java -> LoginLab.jsp (Encoded)
- [SECURITY FAILURE Anonymous:574475 at unknown -> /SwingSetInteractive/IntrusionDetector] Authentication failed because user ray_lukas doesn't exist (Encoded)
org.owasp.esapi.errors.AuthenticationCredentialsException: Authentication failed
      at org.owasp.esapi.reference.FileBasedAuthenticator2.loginWithUsernameAndPassword(FileBasedAuthenticator2.java:633)
      at org.owasp.esapi.reference.FileBasedAuthenticator2.login(FileBasedAuthenticator2.java:787)
      at org.owasp.esapi.reference.FileBasedAuthenticator2.login(FileBasedAuthenticator2.java:765)
      at org.apache.jsp.WEB_002dINF.jsp.LoginLab_jsp._jspService(LoginLab_jsp.java:168)
      at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
      at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:377)
      at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:313)
      at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:260)
            so on and so on... ... ...

When I shut down TomCat I get..

Seeking ESAPI.properties
  Not found in 'org.owasp.esapi.resources' directory or file not readable: C:\eclipse\ESAPI.properties
  Not found in SystemResource Directory/resourceDirectory: null/ESAPI.properties
  Not found in SystemResource Directory/.esapi: .esapi/ESAPI.properties
  Not found in SystemResource Directory: ESAPI.properties
  Not found in 'user.home' directory: C:\eclipse\ESAPI.properties
  Not found on classpath
  Not found anywhere


Notice that user.home now points to my eclipse directory.. that seems odd.. when I started the server the  directory was: C:\Documents and Settings\v9234s32\.esapi

could someone drop me a hint.. sorry for the long email..
thanks guys..

ray lukas
Software Engineer
SuperMedia LLC
 M: 508.314.4257
www.supermedia.com<http://www.supermedia.com>

[cid:image001.gif at 01CC26C5.0AEF9CF0][cid:image002.gif at 01CC26C5.0AEF9CF0]

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.owasp.org/pipermail/esapi-user/attachments/20110609/2169898a/attachment.html 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.gif
Type: image/gif
Size: 73 bytes
Desc: image001.gif
Url : https://lists.owasp.org/pipermail/esapi-user/attachments/20110609/2169898a/attachment.gif 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image002.gif
Type: image/gif
Size: 5912 bytes
Desc: image002.gif
Url : https://lists.owasp.org/pipermail/esapi-user/attachments/20110609/2169898a/attachment-0001.gif 


More information about the Esapi-user mailing list