[Esapi-user] [Esapi-dev] ESAPI 1.4

Jim Manico jim.manico at owasp.org
Thu Feb 3 13:10:59 EST 2011


This is a very good suggestion. I like it a lot better than calling 1.4 "beta".

I'll make this move shortly after discussing this with the leadership team at the summit.

-Jim Manico
http://manico.net

On Feb 3, 2011, at 8:19 AM, "Calderon, Juan Carlos (GE, Corporate, consultant)"<juan.calderon at ge.com> wrote:

> I second the honesty pledge
> 
> However, "demoting to beta" sounds a little weird to me, can you
> actually do that? IFAIK "Beta" is Latin for "still doesn't work", but
> ESAPI 1.4 was already in use and in production and also publicized as
> release level.
> 
> IMHO, a status of "unsupported" or similar will better express the
> situation and will be more natural to people to understand. Also we can
> encourage people to use ESAPI 2.0 instead.
> 
> Regards,
> Juan C Calderon
> 
> -----Original Message-----
> From: esapi-dev-bounces at lists.owasp.org
> [mailto:esapi-dev-bounces at lists.owasp.org] On Behalf Of Jim Manico
> Sent: Wednesday, February 02, 2011 8:41 PM
> To: ESAPI-Developers; ESAPI Users List
> Subject: [Esapi-dev] ESAPI 1.4
> 
> Folks,
> 
> We need to demote ESAPI 1.4 to BETA. It's the honest thing to do (it's
> terribly out of date by over a year).
> 
> This is not a politically good thing to do. But it is the technically
> honest and right thing to do, in my opinion.
> 
> Thoughts?
> 
> - Jim
> _______________________________________________
> Esapi-dev mailing list
> Esapi-dev at lists.owasp.org
> https://lists.owasp.org/mailman/listinfo/esapi-dev


More information about the Esapi-user mailing list