[Esapi-user] OWASP configure issue in Oracle App Server 10.1.3

pundarik rajkhowa pundarickr at gmail.com
Tue Nov 16 00:32:17 EST 2010


Hi Jim,

Thanks for the prompt reply..

1.

Did you stage up the configuration files?
--aah, did not quite under what staging up means, but let me explain how I
conigured it. I have put the OWASP jar file( ESAPI-2.0_rc6.jar ) in Oracle
app server lib path which is

D:\product\10.1.3\OracleAS_1\j2ee\home\lib

I have put the ESAPI.properties file in the same path and configured it for
keys and log file. Attached the file.

2.

What version of ESAPI are you using?

-- I am using ESAPI-2.0_rc6.jar for OWASP installation.



3.

Can you send us your log files so we can see what is happening when you
start up the server?

-- I could not find anything specific to OWASP in start up logs. Found a few
reference in the global-application.log as given below..



10/11/15 16:57:28.318 defaultWebApp: JspServlet: unable to dispatch to
requested page: Exception:oracle.jsp.provider.JspCompileException:



<H3>Errors
compiling:D:\product\10.1.3\OracleAS_1\j2ee\home\application-deployments\default\defaultWebApp\persistence\_pages\_portal\_test.java</H3><TABLE
BORDER=1 WIDTH=100%><TR><TH ALIGN=CENTER>Line #</TH><TH
ALIGN=CENTER>Error</TH></TR><TR><TD WIDTH=7% VALIGN=TOP><P
ALIGN=CENTER>16</TD><TD> 'class' or 'interface' expected
import org.owasp.esapi.*;
</TD></TR></TABLE>



hope this helps..



regards,

Pundarik


On Mon, Nov 15, 2010 at 6:47 PM, Jim Manico <jim.manico at owasp.org> wrote:

>  Did you stage up the configuration files?
>
>
>
> What version of ESAPI are you using?
>
>
>
> Can you send us your log files so we can see what is happening when you
> start up the server?
>
>
>
> Thank you,
>
> Jim
>
>
>
> *From:* esapi-user-bounces at lists.owasp.org [mailto:
> esapi-user-bounces at lists.owasp.org] *On Behalf Of *pundarik rajkhowa
> *Sent:* Sunday, November 14, 2010 8:41 PM
> *To:* esapi-user at lists.owasp.org
> *Subject:* [Esapi-user] OWASP configure issue in Oracle App Server 10.1.3
>
>
>
> Hi All,
>
> I am trying to configure OWASP for use in Oracle 10g App Server, but unable
> to do so.I have put the jar file and property file in proper lib path of
> Oracle server, but it is giving "'class' or 'interface' expected import
> org.owasp.esapi.ESAPI;" error. I am using OWASP already in a project hosted
> in Apache Tomcat server and basically following the same installation steps
> for Oracle also.Can somebody guide me ?
> regards,
> Pundarik
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.owasp.org/pipermail/esapi-user/attachments/20101116/3cff709a/attachment.html 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ESAPI.properties
Type: application/octet-stream
Size: 23267 bytes
Desc: not available
Url : https://lists.owasp.org/pipermail/esapi-user/attachments/20101116/3cff709a/attachment.obj 


More information about the Esapi-user mailing list