[Esapi-user] Version question

Kevin W. Wall kevin.w.wall at gmail.com
Mon Jan 4 00:29:07 EST 2010


Johan Lim wrote:
> Hi,
> 
> I am new to ESAPI. I got the following question:
> For ESAPI 1.4 - jar (Java 1.4+) , can I use Java 1.6?
> Thanks

Yes, you should be to, as JDKs are generally _backward_ compatible.
If you have should have some trouble though, just compile using

	javac -target 1.4 ....other_args....

However, I don't think you will have any problems other than possibly some
seeing warnings about where generics are not used for strong typing.

-kevin
-- 
Kevin W. Wall
"The most likely way for the world to be destroyed, most experts agree,
is by accident. That's where we come in; we're computer professionals.
We cause accidents."        -- Nathaniel Borenstein, co-creator of MIME


More information about the Esapi-user mailing list