[Owasp-modsecurity-core-rule-set] Lua nil value error

Ross Lawrie ross at sentrypayments.com
Wed Nov 9 12:48:50 EST 2011


On Wed, 2011-11-09 at 10:10 +0200, Josh Amishav-Zlatin wrote:
> On Tue, Nov 8, 2011 at 6:59 PM, Ross Lawrie <ross at sentrypayments.com> wrote:
> 
> > This did help a little, the path was in need of updating, so I made that
> > change, but the problem persisted. This lead me to try running the lua
> > scripts from the command line which resulted in "module 'rex_pcre' not
> > found". I'm wondering if anyone is aware of a Debian (lenny) rex_pcre
> 
> Hi Ross,
> 
> Have you tried liblua5.1-rex-pcre0?
> 
> --
>  - Josh

Josh,

Unfortunately that package doesn't exist for Debian Lenny (5.0.9). It
looks like it exists for Squeeze and higher, but at this point I can't
quite migrate this system to Squeeze. Thanks!

Ross.



More information about the Owasp-modsecurity-core-rule-set mailing list